package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\+)?(0|27)([5-9])([0-9])( )?([0-9]{3})( )?([0-9]{4})$`)
var str = `+27827860965
27827860965
0827860965
034567891
082 786 0965
+2782 786 0965
2782 786 0965`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}