$re = '/^(\+)?(0|27)([5-9])([0-9])( )?([0-9]{3})( )?([0-9]{4})$/m';
$str = '+27827860965
27827860965
0827860965
034567891
082 786 0965
+2782 786 0965
2782 786 0965';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);