import Foundation
let pattern = ##"^GET\ (\/([^\s?#]+)?([?][^?#]*)?(#.*)?)?"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
GET /flussonic_event.php HTTP/1.1
GET /tnt/index.m3u8 HTTP/1.1
GET /tnt HTTP/1.1
GET /tnt/mpegts HTTP/1.1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}