import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^GET\\ (\\/([^\\s?#]+)?([?][^?#]*)?(#.*)?)?";
final String string = "GET /flussonic_event.php HTTP/1.1\n"
+ "GET /tnt/index.m3u8 HTTP/1.1\n"
+ "GET /tnt HTTP/1.1\n"
+ "GET /tnt/mpegts HTTP/1.1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}