const regex = /^GET\ (\/([^\s?#]+)?([?][^?#]*)?(#.*)?)?/sm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^GET\\ (\\\/([^\\s?#]+)?([?][^?#]*)?(#.*)?)?', 'sm')
const str = `GET /flussonic_event.php HTTP/1.1
GET /tnt/index.m3u8 HTTP/1.1
GET /tnt HTTP/1.1
GET /tnt/mpegts HTTP/1.1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}