re = /^GET\ (\/([^\s?#]+)?([?][^?#]*)?(#.*)?)?/m
str = 'GET /flussonic_event.php HTTP/1.1
GET /tnt/index.m3u8 HTTP/1.1
GET /tnt HTTP/1.1
GET /tnt/mpegts HTTP/1.1
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end