import Foundation
let pattern = ###"^##api(?<apicont>.+?)##.+?Функция\s+(?<funcname>.+?)\((?<funcparam>.+?)\)\s+{"###
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .dotMatchesLineSeparators])
let testString = ###"""
##api
# @param лс - обязательный параметр. row_id ЛСа/дома/квартира
# @param наДату - обязательный параметр. Дата, на которую должена действовать УК
# @param результат - не обязательный параметр. Может быть только строкой (ЛСID, УКДатНач, УКДатКнц, ОрганизацияID, Название, Наименование, ДоговорID, Номер, ККС, ДоговорДатНач, ДоговорДатКнц, Объект_Организация, Объект_Договор), по умолчанию - пустая строка, определяет что вернуть в качестве результата, массив, конкретное поле или объект
# @param дом - не обязательный параметр. row_id дома, для проверки кеша
# @description возвращает массив с собранными данными об УК
##
Функция ПолучитьУКпоЛС(лс, наДату, ...) {
##api
# @param лс - обязательный параметр. row_id ЛСа/дома/квартира
# @param наДату - обязательный параметр. Дата, на которую должена действовать УК
# @param результат - не обязательный параметр. Может быть только строкой (ЛСID, УКДатНач, УКДатКнц, ОрганизацияID, Название, Наименование, ДоговорID, Номер, ККС, ДоговорДатНач, ДоговорДатКнц, Объект_Организация, Объект_Договор), по умолчанию - пустая строка, определяет что вернуть в качестве результата, массив, конкретное поле или объект
# @param дом - не обязательный параметр. row_id дома, для проверки кеша
# @description возвращает массив с собранными данными об УК
##
Функция ПолучитьУКпоЛС(лс, наДату, ...) {
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}