// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sim)^##api(?<apicont>.+?)##.+?Функция\s+(?<funcname>.+?)\((?<funcparam>.+?)\)\s+{").unwrap();
let string = "##api
# @param лс - обязательный параметр. row_id ЛСа/дома/квартира
# @param наДату - обязательный параметр. Дата, на которую должена действовать УК
# @param результат - не обязательный параметр. Может быть только строкой (ЛСID, УКДатНач, УКДатКнц, ОрганизацияID, Название, Наименование, ДоговорID, Номер, ККС, ДоговорДатНач, ДоговорДатКнц, Объект_Организация, Объект_Договор), по умолчанию - пустая строка, определяет что вернуть в качестве результата, массив, конкретное поле или объект
# @param дом - не обязательный параметр. row_id дома, для проверки кеша
# @description возвращает массив с собранными данными об УК
##
Функция ПолучитьУКпоЛС(лс, наДату, ...) {
##api
# @param лс - обязательный параметр. row_id ЛСа/дома/квартира
# @param наДату - обязательный параметр. Дата, на которую должена действовать УК
# @param результат - не обязательный параметр. Может быть только строкой (ЛСID, УКДатНач, УКДатКнц, ОрганизацияID, Название, Наименование, ДоговорID, Номер, ККС, ДоговорДатНач, ДоговорДатКнц, Объект_Организация, Объект_Договор), по умолчанию - пустая строка, определяет что вернуть в качестве результата, массив, конкретное поле или объект
# @param дом - не обязательный параметр. row_id дома, для проверки кеша
# @description возвращает массив с собранными данными об УК
##
Функция ПолучитьУКпоЛС(лс, наДату, ...) {";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}