package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sim)^##api(?<apicont>.+?)##.+?Функция\s+(?<funcname>.+?)\((?<funcparam>.+?)\)\s+{`)
var str = `##api
# @param лс - обязательный параметр. row_id ЛСа/дома/квартира
# @param наДату - обязательный параметр. Дата, на которую должена действовать УК
# @param результат - не обязательный параметр. Может быть только строкой (ЛСID, УКДатНач, УКДатКнц, ОрганизацияID, Название, Наименование, ДоговорID, Номер, ККС, ДоговорДатНач, ДоговорДатКнц, Объект_Организация, Объект_Договор), по умолчанию - пустая строка, определяет что вернуть в качестве результата, массив, конкретное поле или объект
# @param дом - не обязательный параметр. row_id дома, для проверки кеша
# @description возвращает массив с собранными данными об УК
##
Функция ПолучитьУКпоЛС(лс, наДату, ...) {
##api
# @param лс - обязательный параметр. row_id ЛСа/дома/квартира
# @param наДату - обязательный параметр. Дата, на которую должена действовать УК
# @param результат - не обязательный параметр. Может быть только строкой (ЛСID, УКДатНач, УКДатКнц, ОрганизацияID, Название, Наименование, ДоговорID, Номер, ККС, ДоговорДатНач, ДоговорДатКнц, Объект_Организация, Объект_Договор), по умолчанию - пустая строка, определяет что вернуть в качестве результата, массив, конкретное поле или объект
# @param дом - не обязательный параметр. row_id дома, для проверки кеша
# @description возвращает массив с собранными данными об УК
##
Функция ПолучитьУКпоЛС(лс, наДату, ...) {`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}