const regex = /^##api(?<apicont>.+?)##.+?Функция\s+(?<funcname>.+?)\((?<funcparam>.+?)\)\s+{/sim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^##api(?<apicont>.+?)##.+?Функция\\s+(?<funcname>.+?)\\((?<funcparam>.+?)\\)\\s+{', 'sim')
const str = `##api
# @param лс - обязательный параметр. row_id ЛСа/дома/квартира
# @param наДату - обязательный параметр. Дата, на которую должена действовать УК
# @param результат - не обязательный параметр. Может быть только строкой (ЛСID, УКДатНач, УКДатКнц, ОрганизацияID, Название, Наименование, ДоговорID, Номер, ККС, ДоговорДатНач, ДоговорДатКнц, Объект_Организация, Объект_Договор), по умолчанию - пустая строка, определяет что вернуть в качестве результата, массив, конкретное поле или объект
# @param дом - не обязательный параметр. row_id дома, для проверки кеша
# @description возвращает массив с собранными данными об УК
##
Функция ПолучитьУКпоЛС(лс, наДату, ...) {
##api
# @param лс - обязательный параметр. row_id ЛСа/дома/квартира
# @param наДату - обязательный параметр. Дата, на которую должена действовать УК
# @param результат - не обязательный параметр. Может быть только строкой (ЛСID, УКДатНач, УКДатКнц, ОрганизацияID, Название, Наименование, ДоговорID, Номер, ККС, ДоговорДатНач, ДоговорДатКнц, Объект_Организация, Объект_Договор), по умолчанию - пустая строка, определяет что вернуть в качестве результата, массив, конкретное поле или объект
# @param дом - не обязательный параметр. row_id дома, для проверки кеша
# @description возвращает массив с собранными данными об УК
##
Функция ПолучитьУКпоЛС(лс, наДату, ...) {`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}