re = /[^a-z\d-]/m
str = ' testando um nome de flag-uhuu-com-acento-ão_2 @!´`~]][[[
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result