$re = '`[^a-z\d-]`m';
$str = ' testando um nome de flag-uhuu-com-acento-ão_2 @!´`~]][[[
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;