const regex = new RegExp('[^a-z\\d-]', 'gm')
const str = ` testando um nome de flag-uhuu-com-acento-ão_2 @!´\`~]][[[
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);