using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^a-z\d-]";
string substitution = @"";
string input = @" testando um nome de flag-uhuu-com-acento-ão_2 @!´`~]][[[
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}