// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[a-zA-z]*statin[a-zA-Z]*\b").unwrap();
let string = "statin
coveragestatingsffs
simvastatin
random_statin
)statin)
help I need statin
statin needs help
fffstatin help
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}