const regex = /\b[a-zA-z]*statin[a-zA-Z]*\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[a-zA-z]*statin[a-zA-Z]*\\b', 'gm')
const str = `statin
coveragestatingsffs
simvastatin
random_statin
)statin)
help I need statin
statin needs help
fffstatin help
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}