package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[a-zA-z]*statin[a-zA-Z]*\b`)
var str = `statin
coveragestatingsffs
simvastatin
random_statin
)statin)
help I need statin
statin needs help
fffstatin help
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}