$re = '/\b[a-zA-z]*statin[a-zA-Z]*\b/m';
$str = 'statin
coveragestatingsffs
simvastatin
random_statin
)statin)
help I need statin
statin needs help
fffstatin help
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);