re = /\+?(254|0)7\d{8}/
str = '+254712345678
0712345678
254712345678
+254071234567
+256712345678'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end