package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\+?(254|0)7\d{8}`)
var str = `+254712345678
0712345678
254712345678
+254071234567
+256712345678`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}