$re = '/\+?(254|0)7\d{8}/';
$str = '+254712345678
0712345678
254712345678
+254071234567
+256712345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);