using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\+?(254|0)7\d{8}";
string input = @"+254712345678
0712345678
254712345678
+254071234567
+256712345678";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}