re = /^[a-zA-Z0-9\-\_]*+$/m
str = 'test
test
te st
te-st
te_st
t0st
test-_1
1
2
_
-
+'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end