#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9\-\_]*+$"
Local $sString = "test" & @CRLF & _
"test " & @CRLF & _
"te st" & @CRLF & _
"te-st" & @CRLF & _
"te_st" & @CRLF & _
"t0st" & @CRLF & _
"test-_1" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"_" & @CRLF & _
"-" & @CRLF & _
"+"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")