$re = '/^[a-zA-Z0-9\-\_]*+$/m';
$str = 'test
test
te st
te-st
te_st
t0st
test-_1
1
2
_
-
+';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);