import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9\\-\\_]*+$";
final String string = "test\n"
+ "test \n"
+ "te st\n"
+ "te-st\n"
+ "te_st\n"
+ "t0st\n"
+ "test-_1\n"
+ "1\n"
+ "2\n"
+ "_\n"
+ "-\n"
+ "+";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}