# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s(?=[\s\":{}])"
test_str = ("{\n"
" \"failure\": {\n"
" \"type\": \"Blah\",\n"
" \"message\": \"Unrecognised Message: \\\"Good job!\\\" Sir\"\n"
" }\n"
"}")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.