#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s(?=[\s":{}])"
Local $sString = "{" & @CRLF & _
" "failure": {" & @CRLF & _
" "type": "Blah"," & @CRLF & _
" "message": "Unrecognised Message: \"Good job!\" Sir"" & @CRLF & _
" }" & @CRLF & _
"}"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)