$re = '/\s(?=[\s":{}])/';
$str = '{
"failure": {
"type": "Blah",
"message": "Unrecognised Message: \\"Good job!\\" Sir"
}
}';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;