use strict;
my $str = '{
"failure": {
"type": "Blah",
"message": "Unrecognised Message: \\"Good job!\\" Sir"
}
}';
my $regex = qr/\s(?=[\s":{}])/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";