re = /[9][2-5]\d{7}/m
str = '929164344
915392194
943757798
922955344
914094882
990824719
991259647
925212121
954000000
964000000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end