import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[9][2-5]\\d{7}";
final String string = "929164344\n"
+ "915392194\n"
+ "943757798\n"
+ "922955344\n"
+ "914094882\n"
+ "990824719\n"
+ "991259647\n"
+ "925212121\n"
+ "954000000\n"
+ "964000000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}