$re = '/[9][2-5]\d{7}/m';
$str = '929164344
915392194
943757798
922955344
914094882
990824719
991259647
925212121
954000000
964000000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);