const regex = /[9][2-5]\d{7}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[9][2-5]\\d{7}', 'gm')
const str = `929164344
915392194
943757798
922955344
914094882
990824719
991259647
925212121
954000000
964000000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}