$re = '/^([\w.]{1,})\.([\w]{3,4})\.([\w]{3,4})$/m';
$str = 'file.txt
file.txt.txt
file.one.two.thre
file.one.two.three
file.google.txt.jar
jim.joe.chris
something.filename.pdf.lnk
filename.pdf.123
thisfile.hasadotbutonlyone.exe
thisfile.xlsx.xlsx
thisfile.12.123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);