const regex = /^([\w.]{1,})\.([\w]{3,4})\.([\w]{3,4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\w.]{1,})\\.([\\w]{3,4})\\.([\\w]{3,4})$', 'gm')
const str = `file.txt
file.txt.txt
file.one.two.thre
file.one.two.three
file.google.txt.jar
jim.joe.chris
something.filename.pdf.lnk
filename.pdf.123
thisfile.hasadotbutonlyone.exe
thisfile.xlsx.xlsx
thisfile.12.123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}