package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\w.]{1,})\.([\w]{3,4})\.([\w]{3,4})$`)
var str = `file.txt
file.txt.txt
file.one.two.thre
file.one.two.three
file.google.txt.jar
jim.joe.chris
something.filename.pdf.lnk
filename.pdf.123
thisfile.hasadotbutonlyone.exe
thisfile.xlsx.xlsx
thisfile.12.123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}