use strict;
my $str = 'file.txt
file.txt.txt
file.one.two.thre
file.one.two.three
file.google.txt.jar
jim.joe.chris
something.filename.pdf.lnk
filename.pdf.123
thisfile.hasadotbutonlyone.exe
thisfile.xlsx.xlsx
thisfile.12.123';
my $regex = qr/^([\w.]{1,})\.([\w]{3,4})\.([\w]{3,4})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}