import Foundation
let pattern = #"^((?'isolated_keywords'('none')|(deny))|((?'single'(?'just_scheme'[a-z]+\:)|(?'uri'(?'scheme'[a-z]+\:(?'scheme_separator'\/\/)?)?(?'host'[a-z0-9\-*]+\.[a-z0-9\-*.]+)(?'port':[0-9*]+)?)|('self')|(sameorigin))(?'list'((?'list_separator'\ )(?'list_content'(?'just_scheme_in_list'[a-z]+\:)|(?'uri_in_list'(?'scheme_in_list'[a-z]+\:(?'scheme_separator_in_list'\/\/)?)?(?'host_in_list'[a-z0-9\-*]+\.[a-z0-9\-*.]+)?(?'port_in_list':[0-9*]+)?)))+)?))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
'self'
sameorigin plus.some.host
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)