const regex = new RegExp('^((?\\'isolated_keywords\\'(\\'none\\')|(deny))|((?\\'single\\'(?\\'just_scheme\\'[a-z]+\\:)|(?\\'uri\\'(?\\'scheme\\'[a-z]+\\:(?\\'scheme_separator\\'\\/\\/)?)?(?\\'host\\'[a-z0-9\\-*]+\\.[a-z0-9\\-*.]+)(?\\'port\\':[0-9*]+)?)|(\\'self\\')|(sameorigin))(?\\'list\\'((?\\'list_separator\\'\\ )(?\\'list_content\\'(?\\'just_scheme_in_list\\'[a-z]+\\:)|(?\\'uri_in_list\\'(?\\'scheme_in_list\\'[a-z]+\\:(?\\'scheme_separator_in_list\\'\\/\\/)?)?(?\\'host_in_list\\'[a-z0-9\\-*]+\\.[a-z0-9\\-*.]+)?(?\\'port_in_list\\':[0-9*]+)?)))+)?))$', 'gm')
const str = `'self'
sameorigin plus.some.host
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}