package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?'isolated_keywords'('none')|(deny))|((?'single'(?'just_scheme'[a-z]+\:)|(?'uri'(?'scheme'[a-z]+\:(?'scheme_separator'\/\/)?)?(?'host'[a-z0-9\-*]+\.[a-z0-9\-*.]+)(?'port':[0-9*]+)?)|('self')|(sameorigin))(?'list'((?'list_separator'\ )(?'list_content'(?'just_scheme_in_list'[a-z]+\:)|(?'uri_in_list'(?'scheme_in_list'[a-z]+\:(?'scheme_separator_in_list'\/\/)?)?(?'host_in_list'[a-z0-9\-*]+\.[a-z0-9\-*.]+)?(?'port_in_list':[0-9*]+)?)))+)?))$`)
var str = `'self'
sameorigin plus.some.host
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}