$re = '/^((?\'isolated_keywords\'(\'none\')|(deny))|((?\'single\'(?\'just_scheme\'[a-z]+\:)|(?\'uri\'(?\'scheme\'[a-z]+\:(?\'scheme_separator\'\/\/)?)?(?\'host\'[a-z0-9\-*]+\.[a-z0-9\-*.]+)(?\'port\':[0-9*]+)?)|(\'self\')|(sameorigin))(?\'list\'((?\'list_separator\'\ )(?\'list_content\'(?\'just_scheme_in_list\'[a-z]+\:)|(?\'uri_in_list\'(?\'scheme_in_list\'[a-z]+\:(?\'scheme_separator_in_list\'\/\/)?)?(?\'host_in_list\'[a-z0-9\-*]+\.[a-z0-9\-*.]+)?(?\'port_in_list\':[0-9*]+)?)))+)?))$/m';
$str = '\'self\'
sameorigin plus.some.host
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);