re = /^0(2|3|4|8|9|7[1-46-9]|5[0-578])[\.-:]?([2-9][0-9]{6})$/
str = '0712506000'
# Print the match result
str.match(re) do |match|
puts match.to_s
end