const regex = /^0(2|3|4|8|9|7[1-46-9]|5[0-578])[\.-:]?([2-9][0-9]{6})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0(2|3|4|8|9|7[1-46-9]|5[0-578])[\\.-:]?([2-9][0-9]{6})$', '')
const str = `0712506000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}