$re = '/^0(2|3|4|8|9|7[1-46-9]|5[0-578])[\.-:]?([2-9][0-9]{6})$/';
$str = '0712506000';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);