package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^0(2|3|4|8|9|7[1-46-9]|5[0-578])[\.-:]?([2-9][0-9]{6})$`)
var str = `0712506000`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}