re = /^[a-z]*p.t.?[a-z]*$/m
str = 'pit
spot
spate
slap two
respite
pt
Pot
peat
part
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end