#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z]*p.t.?[a-z]*$"
Local $sString = "pit" & @CRLF & _
"spot" & @CRLF & _
"spate" & @CRLF & _
"slap two" & @CRLF & _
"respite" & @CRLF & _
"pt" & @CRLF & _
"Pot" & @CRLF & _
"peat" & @CRLF & _
"part" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")