$re = '/^[a-z]*p.t.?[a-z]*$/m';
$str = 'pit
spot
spate
slap two
respite
pt
Pot
peat
part
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);