package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z]*p.t.?[a-z]*$`)
var str = `pit
spot
spate
slap two
respite
pt
Pot
peat
part
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}